Click Here To Print
Product Detail

2016 Environment of Care Essentials for Health Care. Text with Flashdrive

2016 Environment of Care Essentials for Health Care. Text with Flashdrive Cover Image
Pricing & Availability
Available: 0
List Price:$159.00

Book Information
Edition: 1st
Publisher: Joint Commission Resources
ISBN: 1-59940-927-5 (1599409275)
ISBN-13: 978-1-59940-927-6 (9781599409276)
New Edition: 1-59940-982-8
Old Edition: 1-59940-886-4
Binding: Book with Ancillary Spiral Bound + Flash Drive
Copyright: 2016
Publish Date: 01/16
Volume: 2016
Weight: 1.32 Lbs.
Pages: 196
Subject Class: M-A (Medical Administration and Health Policy)
A New Edition of this Title is Available
Return Policy: This product contains software or Internet access code(s). Returns are not accepted if seal is broken or if access code revealed.
Class Specifications
Discipline: Hospitals
Subject Definition: Health Facility Environment; Safety Management Standards
NLM Class: WX 165
LC Class: RA971
Abstract: Get ready for survey with the one book that bundles all the EC, EM, and LS standards and elements of performance in one convenient reference! The 2016 Environment of Care Essentials for Health Care is a compact, easy-to-use compendium of environment of care (EC), emergency management (EM), and life safety (LS) standards and elements of performance. This indispensable spiral-bound volume displays EC, EM, and LS requirements in a grid format, enabling users to quickly compare physical environment, emergency management, and life safety requirements across all settings to help streamline compliance efforts. You can order it as an e-book or purchase a hard copy book with an electronic version of the standards grid included as a bonus!

Follow Matthews Book Co. on:
Follow Matthews Book Co. on Twitter

Copyright © 2001-2018 Matthews Book Company - All rights reserved. - 11559 Rock Island Ct., Maryland Heights, MO, 63043 - (800) MED-BOOK
Matthews Privacy Statement | Return Policy This web site is best viewed with: Internet Explorer 5.5+, Firefox 1.5+, and Netscape 6.0+